Beaglebone Black bekommt keine WUs

Fehler und Wünsche zum Projekt yoyo@home
Bugs and wishes for the project yoyo@home
Nachricht
Autor
Octoate
PDA-Benutzer
PDA-Benutzer
Beiträge: 48
Registriert: 04.06.2007 07:52
Wohnort: NRW
Kontaktdaten:

Beaglebone Black bekommt keine WUs

#1 Ungelesener Beitrag von Octoate » 21.04.2021 12:09

Hi,
ich habe vor kurzem mal meine alten SBC ARM Systeme wieder in Betrieb genommen und auf allen Systemen BOINC installiert und Yoyo@home als Projekt hinzugefügt. Alle Systeme arbeiten auch fleissig an ihren WUs, allerdings bekommen die beiden keine WUs. Mein Fokus liegt hier momentan auf OGR, also habe ich den offiziellen Dnetc Client mal installiert und getestet. Nach dem Symlink aus der FAQ von Yoyo@home hat das dann auch geklappt. Kann es evtl. daran liegen, dass sich das System als "arm-unknown-linux-gnueabihf" meldet?

Hier mal die Messages vom Boinc Client:

Code: Alles auswählen

1: 21-Apr-2021 11:33:21 (low) [] Starting BOINC client version 7.14.2 for arm-unknown-linux-gnueabihf
2: 21-Apr-2021 11:33:21 (low) [] log flags: file_xfer, sched_ops, task
3: 21-Apr-2021 11:33:21 (low) [] Libraries: libcurl/7.64.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
4: 21-Apr-2021 11:33:21 (low) [] Data directory: /var/lib/boinc-client
5: 21-Apr-2021 11:33:23 (low) [] No usable GPUs found
6: 21-Apr-2021 11:33:27 (low) [] [libc detection] gathered: 2.28, Debian GLIBC 2.28-10
7: 21-Apr-2021 11:33:27 (low) [] Host name: node5
8: 21-Apr-2021 11:33:27 (low) [] Processor: 1 ARM ARMv7 Processor rev 2 (v7l) [Impl 0x41 Arch 7 Variant 0x3 Part 0xc08 Rev 2]
9: 21-Apr-2021 11:33:27 (low) [] Processor features: half thumb fastmult vfp edsp thumbee neon vfpv3 tls vfpd32
10: 21-Apr-2021 11:33:27 (low) [] OS: Linux Debian: Debian GNU/Linux 10 (buster) [4.19.94-ti-r42|libc 2.28 (Debian GLIBC 2.28-10)]
11: 21-Apr-2021 11:33:27 (low) [] Memory: 483.42 MB physical, 0 bytes virtual
12: 21-Apr-2021 11:33:27 (low) [] Disk: 3.53 GB total, 997.14 MB free
13: 21-Apr-2021 11:33:27 (low) [] Local time is UTC +2 hours
14: 21-Apr-2021 11:33:27 (low) [] Config: GUI RPCs allowed from:
15: 21-Apr-2021 11:33:27 (low) [yoyo@home] URL http://www.rechenkraft.net/yoyo/; Computer ID 502852; resource share 25
16: 21-Apr-2021 11:33:27 (low) [] General prefs: from https://bam.boincstats.com/ (last modified 28-Feb-2021 15:03:21)
17: 21-Apr-2021 11:33:27 (low) [] Host location: none
18: 21-Apr-2021 11:33:27 (low) [] General prefs: using your defaults
19: 21-Apr-2021 11:33:27 (low) [] Reading preferences override file
20: 21-Apr-2021 11:33:27 (low) [] Preferences:
21: 21-Apr-2021 11:33:27 (low) [] max memory usage when active: 290.05 MB
22: 21-Apr-2021 11:33:27 (low) [] max memory usage when idle: 435.08 MB
23: 21-Apr-2021 11:33:27 (low) [] max disk usage: 0.00 GB
24: 21-Apr-2021 11:33:27 (low) [] (to change preferences, visit a project web site or select Preferences in the Manager)
25: 21-Apr-2021 11:33:27 (low) [] Setting up project and slot directories
26: 21-Apr-2021 11:33:27 (low) [] Checking active tasks
27: 21-Apr-2021 11:33:27 (low) [] Using account manager BOINCstatsBAM!
28: 21-Apr-2021 11:33:27 (low) [] Setting up GUI RPC socket
29: 21-Apr-2021 11:33:27 (low) [] gui_rpc_auth.cfg is empty - no GUI RPC password protection
30: 21-Apr-2021 11:33:27 (low) [] Checking presence of 6 project files
31: 21-Apr-2021 11:33:28 (low) [yoyo@home] Sending scheduler request: To fetch work.
32: 21-Apr-2021 11:33:28 (low) [yoyo@home] Requesting new tasks for CPU
33: 21-Apr-2021 11:33:31 (low) [yoyo@home] Scheduler request completed: got 0 new tasks
34: 21-Apr-2021 11:33:31 (low) [yoyo@home] No work sent
35: 21-Apr-2021 11:33:31 (low) [yoyo@home] No work is available for Cruncher ogr
36: 21-Apr-2021 11:42:47 (low) [yoyo@home] Sending scheduler request: To fetch work.
37: 21-Apr-2021 11:42:47 (low) [yoyo@home] Requesting new tasks for CPU
38: 21-Apr-2021 11:42:50 (low) [yoyo@home] Scheduler request completed: got 0 new tasks
39: 21-Apr-2021 11:42:50 (low) [yoyo@home] No work sent
40: 21-Apr-2021 11:42:50 (low) [yoyo@home] No work is available for Cruncher ogr
Bild

Benutzeravatar
joe carnivore
Team-Joker
Team-Joker
Beiträge: 340
Registriert: 04.05.2013 06:01
Wohnort: Goslar

Re: Beaglebone Black bekommt keine WUs

#2 Ungelesener Beitrag von joe carnivore » 21.04.2021 16:49

Ich weis nicht ob es bei dir hilft , einfach mal in die cc_config dieses einsetzen.

<cc_config>
<options>
<alt_platform>arm-unknown-linux-gnueabihf</alt_platform>
</options>
</cc_config>
Bild
Bild

Octoate
PDA-Benutzer
PDA-Benutzer
Beiträge: 48
Registriert: 04.06.2007 07:52
Wohnort: NRW
Kontaktdaten:

Re: Beaglebone Black bekommt keine WUs

#3 Ungelesener Beitrag von Octoate » 21.04.2021 20:00

Leider nicht. Er bekommt immer noch keine neuen WUs. Ausgabe bleibt gleich, bis auf die zusätzliche Zeile

Code: Alles auswählen

15: 21-Apr-2021 20:56:34 (low) [] Config: alternate platform: arm-unknown-linux-gnueabihf
Bild

smoe
Prozessor-Polier
Prozessor-Polier
Beiträge: 120
Registriert: 12.01.2018 19:12

Re: Beaglebone Black bekommt keine WUs

#4 Ungelesener Beitrag von smoe » 21.04.2021 21:22

Was ist denn mit anderen ARM-unterstützenden Projekten wie das WorldCommunityGrid?

Benutzeravatar
yoyo
Vereinsvorstand
Vereinsvorstand
Beiträge: 7915
Registriert: 17.12.2002 14:09
Wohnort: Berlin
Kontaktdaten:

Re: Beaglebone Black bekommt keine WUs

#5 Ungelesener Beitrag von yoyo » 21.04.2021 21:35

Setze als alternate platform mal: arm-linux-gnu
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Bild Bild

Benutzeravatar
yoyo
Vereinsvorstand
Vereinsvorstand
Beiträge: 7915
Registriert: 17.12.2002 14:09
Wohnort: Berlin
Kontaktdaten:

Re: Beaglebone Black bekommt keine WUs

#6 Ungelesener Beitrag von yoyo » 21.04.2021 21:39

Aber ich vermute das Problem ist:
23: 21-Apr-2021 11:33:27 (low) [] max disk usage: 0.00 GB
Die Workunit darf maximal 0 GB disk benutzen. Workunits mit sowenig DIsk Anforderungen hab ich nicht.
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Bild Bild

Octoate
PDA-Benutzer
PDA-Benutzer
Beiträge: 48
Registriert: 04.06.2007 07:52
Wohnort: NRW
Kontaktdaten:

Re: Beaglebone Black bekommt keine WUs

#7 Ungelesener Beitrag von Octoate » 22.04.2021 06:03

Hmm... klingt ganz danach. Laut dem System habe ich noch 998MB freien Speicher auf der eMMC des BBB. In BAM habe ich die Nutzung des freien Speichers auf 50% gesetzt. Das sollte eigentlich locker für zwei WUs ausreichen.

UPDATE: Hab in BAM mal "Leave at least free" auf 0 GB eingestellt. Jetzt sind WUs auf dem System angekommen und rechnen vor sich hin. Klappt also. Mal schauen, dass OGR dann dieses Jahr noch fertig wird :wink:. Danke für die Hilfe :D!
Bild

Antworten

Zurück zu „Fehler, Wünsche / Bugs, Wishes“